วิธี Downgrade ปลั๊กอิน และธีม WordPress ด้วยปลั๊กอิน WP Rollback

Downgrade ปลั๊กอิน

หลายๆ ครั้งเราจำเป็นต้องมีการ Downgrade ปลั๊กอิน ให้เป็นเวอร์ชั่นเก่า หากเว็บเรามี Error หรือพัง หลังจากที่เรากดอัพเดทปลั๊กอินบางตัว

เพราะบางครั้งปลั๊กอินบางตัวที่มีผู้ใช้งานเยอะๆ เช่น Woocommerce มีการปรับปรุงและพัฒนาตัวเองตลอดเวลา ทั้งในเรื่องของความปลอดภัย และการใช้งานให้มีประสิทธิภาพยิ่งขึ้น

ในทุกครั้งๆ ที่ WordPress และ Woocommerce มีการอัพเดท บรรดาธีมที่ดีทั้งหมด ต้องมีการอัพเดทตัวเองให้รองรับกับ WordPress และ Woocommerce ซึ่งแน่นอน ในบางครั้ง ผู้สร้างธีมต้องใช้เวลาทดสอบธีมของตัวเอง และแก้ไข Bug ต่างๆ ที่เกิดขึ้น ทำให้เขาปล่อย Theme ตัวอัพเดทล่าสุดออกมาช้า

ในหลายๆครั้ง  User บางคนที่ใจร้อนเมื่อเห็นการแจ้งเตือน อัพเดทปลั๊กอิน จึงมือไว กดอัพเดททันที จึงทำให้เกิดปัญหาปลั๊กอินตีกันกับธีม และทำให้เว็บมีการแสดงผลที่ไม่เหมือนเดิม เช่น รูปไม่แสดง แสดงข้อมูลเพี้ยน เกิดปัญหาเว็บหน้าขาว Error 500 เป็นต้น

ตัวอย่าง Error ล่าสุดที่เจอเมื่อเราใจร้อนอัพเดท Woocommerce รูปภาพที่ category product หายไป

picture error woocommerce

ทางแก้ปัญหาปลั๊กอินตีกัน หรือ Error พวกนี้มีอยู่ 2 ทาง คือ

1. อัพเดทธีม ให้เป็นเวอร์ชั่น ล่าสุด ที่รองรับ Woocommerce 3.3.0

สำหรับวิธีการอัพเดทธีมและปลั๊กอิน เข้าไปดูวิธีการทำได้ที่บทความนี้ อัพเดท WordPress อัพเดทธีม อัพเดทปลั๊กอิน อย่างไรให้ถูกต้อง

2. Downgrade ปลั๊กอิน กลับมาใช้เวอร์ชั่นเก่า คือ Woocommerce 3.2.6 แทน

วิธีการมีดังนี้

2.1 ติดตั้งปลั๊กอิน WP Rollback

wp rollback

2.2 เข้าไป Downgrade plugin ที่เราต้องการ

โดยให้เราเข้าไปที่ plugin > installed plugins จากนั้นให้สังเกตที่ใต้ล่างชื่อของปลั๊กอินแต่ละตัว จะมีคำว่า Rollback ปรากฏอยู่

Downgrade ปลั๊กอิน

2.3 ให้เราคลิกที่ Rollback แล้วเลือก Version ของ plugin ที่เราต้องการ downgrade ลงมาได้เลย

downgrade plugin

จากรูปผมเลือก Downgrade เวอร์ชั่นของ Woocommerce ลงมาใช้เวอร์ชั่นเก่าคือ 3.2.6 เนื่องจากธีมที่ผมใช้ผู้สร้างธีมเขายังไม่ได้ปล่อยตัวอัพเดทล่าสุดออกมา

สรุป

คำแนะนำเลยๆ หากไม่อยากให้เว็บพัง เมื่อมีการแจ้งเตือนอัพเดทใดๆ ไม่ว่าจะเป็น Wp, Theme หรือ plugin เรายังไม่ควรรีบร้อนกดอัพเดท รอดูการ comment จากผู้ใช้งานทั่วโลกก่อน และรอให้ธีมเขาทำการแก้ไขและอัพเดทก่อนเสมอ เมื่อธีมพร้อม ปลั๊กอินตัวอื่นๆ พร้อม แล้วเราจึงค่อยกดอัพเดทได้ครับผม

ปล. ปลั๊กอินนี้ Downgrade ได้เฉพาะธีมและปลั๊กอินตัวฟรี ที่มี Data อยู่บน WordPress.org เท่านั้นนะ

ใส่ความเห็น

อีเมลของคุณจะไม่แสดงให้คนอื่นเห็น ช่องที่ต้องการถูกทำเครื่องหมาย *